A Guide to Using Banner
Contents

Learning the Basics.................................................................4
   Logging on to Banner..........................................................4
   Exiting Banner......................................................................5
Using the Mouse and Keyboard..............................................6
The Main Menu .........................................................................7
Forms....................................................................................8
   Menu Bar..............................................................................10
   File Menu.............................................................................11
   Edit Menu.............................................................................11
   Block Menu...........................................................................12
   Field Menu...........................................................................12
   Record Menu.........................................................................12
   Query Menu..........................................................................13
   Help Menu...........................................................................13
   Toolbars..............................................................................14
   Title Bar...............................................................................14
   Navigation Tabs.....................................................................15
   Auto Hint.............................................................................14
   Status Line............................................................................15
   Key Block.............................................................................15
   Other Blocks.........................................................................15
Types of Forms ......................................................................16
   Application forms..............................................................16
   Query Forms.........................................................................17
   Inquiry Forms......................................................................17
Elements on a form ...............................................................18
   Iconic Buttons......................................................................18
   Response Buttons............................................................19
   Checkboxes.........................................................................19
   Radio Buttons.......................................................................19
   Records, Rows, and Columns............................................19
   Fields..................................................................................20
   Validated Fields....................................................................20
Navigating through Banner..................................................21
Searching in Banner.............................................................22
   Entering a complete ID:....................................................22
   Entering a complete name:................................................22
   Using ‘wildcards’ in searches..........................................23
   Searching by partial ID:....................................................23
   Searching by partial name:..............................................23
   THE ID AND NAME EXTENDED SEARCH WINDOW..............24
   Narrowing (reducing) searches:......................................24
   PERSON SEARCH FORM (SOAIDENT)................................25
   PERSON SEARCH DETAIL FORM (SOAIDNS).....................26
   Using ‘Sounds Like’ searches............................................27
Using the Calendar ..................................................................28
Using the Calculator..................................................................28
Using Help..............................................................................29
My Banner..............................................................................30
   Adding an object to My Banner.........................................31
   Deleting an object from My Banner..................................31
   Adding an object if you know the object’s seven-character name ............................................................................31
Appendix 1: Quick Reference Chart.....................................32
Format Conventions

- On-screen information appears in bold
- Commands and options you select are underlined
- Subsequent directions are indicated by an angle bracket
- Information you must type in is enclosed in square brackets
- Keys that you press are enclosed in angled brackets

Icons

The following icons are used to identify helpful information:

- Timesaver Tip
- Item of Interest
- Warning Message
- Reading
Learning the Basics

How to Log on to Banner 8 PROD

In the Address Block of Internet Explorer type:

- **http://www.banweb.mtu.edu/banner8**
- You then get the following log on screen

![Logon screen](image)

Type in the details as follows:

Username: **kegiddin**
Password: ******

Click on **Connect** or press <Enter>

Once you have completed these steps, the Banner Main Menu appears:

![Banner Main Menu](image)

**Do not use the Return/Enter key to move between the Username and Password fields. Use the Tab key or point and click.**
There will be a second window that must remain open while your Banner session is open.

Exiting Banner

There are several ways to quit/close Banner as shown below. Choose one of these options from the Main Menu.

- Click the Exit button on the horizontal toolbar.
- Press these shortcut keys: Ctrl+q
- Click the close button on the title bar.
- Type Exit in the Go To field.
- Double-click the Banner control icon.
- Click on File>Exit in the menu bar
- Click on File>Exit SCT Banner (This will close all open canvases as well)
Using the Mouse and Keyboard

You can perform Banner functions with either a mouse or keyboard or by using a combination of both. For example, you can save information by clicking a button on the toolbar, selecting an item from a pull-down menu or pressing equivalent key strokes.

Two symbols appear throughout the manuals to indicate the choice of mouse or keyboard instructions:

- Mouse instructions
- Keyboard instructions

**Mouse**

You can use the mouse to navigate to an enterable field, record, block, or window that is currently displayed. You can also use the mouse to click iconic buttons.

**Keyboard Equivalents**

You can use keyboard equivalents for a function depending on your environment – some keystrokes vary from one environment to another. The Help Menu or the Show Keys button on the toolbar lists all keyboard equivalents for the current form, window and field.

To move between fields in a form use the <Tab> key (Next Field) or <Shift+Tab> (Previous Field). In some fields the cursor automatically moves to the next field as soon as you enter the required number of characters.
The Main Menu

The main menu provides an overview of the menus, forms and other information available in Banner. You can use the main menu to navigate through Banner. The main menu has a familiar Windows-style hierarchical tree structure.

- The Product Links at the top of the screen allow you to navigate through the different Banner products.

The large pane of the main menu displays two menus:

- **My Banner.** This menu contains the menus, forms, jobs and QuickFlows most important in the workday of the individual user. This menu is tied to a user’s Oracle user ID.
- **Products Menu.** This menu organizes menus, forms, jobs and QuickFlows.

Expanding and Collapsing Menus

The hierarchical tree structure can be expanded and collapsed:

- When a menu is expanded, the next level of menus is visible.
- When a menu is collapsed, the next level does not appear.

By expanding and collapsing menus, you can easily navigate through Banner. Double click on the file folder to expand the menu so you can see the objects it contains. Double click it again to collapse it.
My Links

You can now add Personal links to the Banner Main Menu. By default, the first 2 and last 2 have been set up for you. You can add links of your own if you would like, and you can change the last two links to something you use more often.

To add or change Personal Links:

1. Access the User Preferences form by going to the file menu and selecting Preferences.
2. Select the My Links Tab
3. Enter the “personal link” name for the link you want to change in the User Value field.
4. Enter the URL (actual web address) for the link you want to change in the next User Value field.
5. Click the Save icon or press the F10 key to save your changes.

Forms

A Banner form is an online document where you can enter and look up information in the database. A form organizes information – information is entered once and then used by other forms and reports or to produce queries.

Forms can include windows, window panes, dialog boxes and alert boxes.
Accessing a Form

There are a number of ways to access a Banner form.

**Go**

1. Type in the seven-character name of the form in the Go To field.

   **Go To...**

2. Press <Enter>.

**OR**

**Main menu**

Select the form from the menu list in Banner.

**OR**

**File pull-down menu**

You can re-access the last 10 forms that were previously opened in the current session.

1. Click on the File pull-down menu.
2. Select the form.

**OR**

**Keystrokes**

1. You can press F5. Enter the Form name in the Go To field.
2. Press <Enter>

**OR**

1. Arrow up or down in the Go To field to access forms used during this session.
2. Press <enter> when the form you want appears in the Go To field

**OR**

1. Click on the File pull-down menu
2. Click on Direct Access
3. Type the seven character name of the form in the Go To field
Parts of a Form

The following figure shows the parts of a Banner form. Each part is described on the following pages.

Menu Bar

The Banner menu bar, located at the top of every form, contains pull-down menus.

File Edit Options Block Item Record Query Tools Help

If a pull-down menu is dimmed, it cannot be accessed.

To access an option on the menu bar:

Mouse
1. Click on the desired pull-down menu name.
2. Click the desired menu item.

Keyboard
1. Press the <Alt> key. The cursor moves to the menu bar.
2. Use the right and left arrow keys to highlight the desired name. Press <Enter>. 
**File Menu**

- **Direct Access** (Go) – Used to access a form by its seven-character name.
- **Object Search** – Used to search for a menu, form, job or QuickFlow with part of the name, description or type.
- **QuickFlow** – Used to access a QuickFlow (see page X).
- **Select** – Selects a field and enters the value into a form.
- **Rollback** – Clears all information (except key information) and returns you to the first field in the key block. On query forms Rollback returns you to the first field on the calling form.
- **Save** – Saves all changes entered since the last time you saved.
- **Refresh** – Clears the message line.
- **Print** – Prints the current window with the date and time in the title bar.
- **Exit** – Exits from the form or window. In the main menu it exits from Banner. In queries it cancels the query.
- **Exit QuickFlow** – Exits from a QuickFlow.
- **Exit SCT Banner** – Exits Banner
- **Return to Menu** - Returns you to the main menu
- **Preferences** – Used to customize Banner.

List of recently accessed forms – Lets you quickly re-access the last 10 forms in the session.

**Edit Menu**

- **Cut** – Cuts selected text and places it on the clipboard.
- **Copy** – Copies selected text to the clipboard.
- **Paste** – Pastes text from the clipboard to the spot where the cursor is located.
- **Edit** – Used to enter or update text (particularly useful in long data fields).

**Options Menu**

- Course Co-Prerequisites
- Course Equivalents
- Course Fee Codes
- Course Degree Attributes
- Course Transfer Institutions
- Course Supplemental Data
- Course Description
- Course Text

Items under the Options Menu will take you to blocks within a form or outside the form to a related form. This menu changes with each form.
Block Menu

Previous – Moves the cursor to the previous block. If the previous block is in another window, that window is opened.

Next – Moves the cursor to the next block. If the next area is in another window, that window is opened.

Clear – Clears all information from the current block (information is not removed from any records or tables).

Item Menu

Previous – Moves the cursor to the previous field in the current block.

Next – Moves the cursor to the next enterable field in the current block.

Clear – Clears all information from the current field (information is not removed from any records or tables).

Duplicate – Duplicates the contents of a field and then copies it into a new record.

Record Menu

Previous – Moves the cursor to the first enterable field in the previous record.

Next – Moves the cursor to the first enterable field in the next record of the current block. If the cursor is in the last record, a new record is created.

Scroll Up – Scrolls up a list of records.

Scroll Down – Scrolls down a list of records.

Clear – Clears all information from the current record (information is not removed from any records or tables).

Remove – Removes all information for the current record. When you Save, the removed information is deleted.

Insert – Inserts a new blank record.

Duplicate – Duplicates the contents of all fields in the record and copies them into a new record.

Lock – Temporarily locks the contents of the record so no other Banner user can update it (depends on user’s rights).
### Query Menu

<table>
<thead>
<tr>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter</td>
</tr>
<tr>
<td>Execute</td>
</tr>
<tr>
<td>Last Criteria</td>
</tr>
<tr>
<td>Cancel</td>
</tr>
<tr>
<td>Count Hits</td>
</tr>
<tr>
<td>Fetch Next Set</td>
</tr>
</tbody>
</table>

*Enter* – Puts the form into query mode so you can enter search criteria to see what information is already in the database.

*Execute* – Searches the database and displays the first set of records that match your search criteria.

*Last Criteria* – Enters the criteria from your last search (enabled only when you are in query mode).

*Cancel* – Cancels the query and takes the form out of query mode.

*Count Hits* – Counts the number of records that match the search criteria and displays that number in the auto hint.

*Fetch Next Set* – If more records meet the search criteria than fit in the window, replaces the current set of displayed records with the next set.

### Help Menu

<table>
<thead>
<tr>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Online Help</td>
</tr>
<tr>
<td>Dynamic Help Query</td>
</tr>
<tr>
<td>Dynamic Help Edit</td>
</tr>
<tr>
<td>Help (Item Properties)</td>
</tr>
<tr>
<td>Show Keys</td>
</tr>
<tr>
<td>List</td>
</tr>
<tr>
<td>Display Error</td>
</tr>
<tr>
<td>Display ID Image</td>
</tr>
<tr>
<td>Calendar</td>
</tr>
<tr>
<td>Calculator</td>
</tr>
<tr>
<td>Extract Data with Key</td>
</tr>
<tr>
<td>Extract Data No Key</td>
</tr>
<tr>
<td>Technical Support</td>
</tr>
<tr>
<td>About SCT Banner</td>
</tr>
</tbody>
</table>

*Online Help* – Takes you to the SCT Banner Help Center

*Dynamic Help Query* – Displays a form in query mode which describes a field, block or form.

*Dynamic Help Edit* – Used to enter your own help notes for a field, block or form.

*Help (Item Properties)* – Displays the properties window for the current field.

*Show Keys* – Displays the Keys list which lists the functions and their keyboard equivalents in the current form, window and field.

*List* – Display the List of Values (LOV) for the current field if List of Values appears in the status line.

*Display Error* – Displays the error code if an error occurs.

*Display Image* – If an image is available, displays the image associated with the ID.

*Calendar* – Displays the calendar.

*Calculator* – Displays the calculator.

*Extract Data with key* - Export data to excel with the header block information

*Extract Data with no key* – Export data to excel without the header block information

*About SCT Banner* – Displays the form which identifies the current form, release number, date and time.
Toolbars

Toolbars are sets of iconic buttons that perform common functions. Banner has two toolbars:

- The horizontal toolbar shown below appears directly under the menu bar.

When you move your cursor to an iconic button and pause, a yellow bubble appears with text that describes the function of the button.

The following iconic buttons are available on the horizontal toolbar:

![Diagram of horizontal toolbar]

Title Bar

The title bar shows the following information:

- Descriptive form name
- Seven-character form name
- Release number
- Database name

Navigation Tabs

The navigation tabs are a way to navigate through forms. It is located near the top of the form.

![Diagram of navigation tabs]

Other Navigational Tools

You can easily move through the different pages by right clicking on the canvas. This is also useful to get commonly used functions like Rollback, Save, Exit, and Print. This is also an easy way to add a form to your Personal Menu.

Auto Hint

The auto hint at the bottom of the form can contain the following information for the field where the cursor is located:

![Diagram of auto hint]
- Brief field description
- Error and processing messages
- Keyboard equivalents, if you can access other blocks, windows, or forms from the field.

**Status Line**

The status line directly under the auto hint can contain one or more of the following messages:

**Record n/n** Shows the number of the current record followed by the total number of records in the current block. If there are more records than fit in the window the total appears as a question mark, e.g. 3/? until you scroll to the last record in the block.

**List of Values** Indicates the field has a List of Values.

**Enter Query** Indicates the form is in query mode.

**Key Block**

The first block on most forms contains key information. All information on the form refers to the key block. Key block information is typically the ID Number, term, course, etc. The key block stays on the form as subsequent blocks appear.

When the cursor is in the key block you can enter information in the fields in the key block area. When you leave the key block the fields are disabled (dimmed).

**Other Blocks**

Other blocks contain additional details for the key information. Each block contains related information.
Types of Forms

Application forms

Application forms are used to enter, update and query information in Banner. This is the most common type of form.

The General Student Form is an example for an application form.
Query Forms

Query forms are used to look up existing information, often returning information to the calling form. You must access a query form from another form. You CANNOT access it directly from the main menu. The Registration Section Query Form is an example.

Inquiry Forms

Inquiry forms are used to look up existing information, often returning information to the calling form. You CAN access an inquiry form from the main menu, from another form, with Go To or with Object Search.
Elements on a form

The following figure shows various elements that appear on forms in Banner.

Buttons

Buttons are visual images used to perform an action or respond to the system.

Iconic Buttons

These buttons are small squares that contain an icon (picture). They represent one or more actions that can be performed for an associated field or record. Michigan Tech uses the following iconic buttons.

<table>
<thead>
<tr>
<th>Iconic Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search</td>
<td>Displays another form or window where you can search for information.</td>
</tr>
<tr>
<td>Data</td>
<td>Indicates that data is available for the associated field.</td>
</tr>
<tr>
<td>Calendar</td>
<td>Displays a calendar for choosing a date.</td>
</tr>
</tbody>
</table>
Response Buttons

These buttons are shaded rectangles that appear in alert boxes and dialogue boxes.

![Yes, No, Cancel]

Checkboxes

Checkboxes are small boxes used to enable or disable features or options. When an option is enabled a check mark appears in the checkbox. When the option is disabled the checkbox is empty.

Radio Buttons

Radio buttons are small circles used to select one of several options in a group. You can pick only one radio button in a group.

Records, Rows, and Columns

Records are sets of related fields, e.g. an address record.

If a block has multiple fields the records often appear in rows and columns. A horizontal scroll bar appears under the columns if all columns don’t fit into the window at once. A vertical scroll bar appears on the right side of the rows if all rows don’t fit into the window at once.

An example of a form showing records, rows and columns is shown below:
Fields

A field in Banner is sometimes called an item, e.g. Next Item, Previous Item and Duplicate Item.

Fields are areas on a form where you can enter, query, change and display information.

<table>
<thead>
<tr>
<th>Enabled</th>
<th>You can put the cursor in the field. Information in the field appears in black text.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Example:</td>
<td>ID: 0000000000 [Blizzard T Husky]</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Disabled</th>
<th>You cannot put the cursor in the field. Information (if it exists) appears in grey text.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Example:</td>
<td>ID: 0000000000 [Blizzard T Husky]</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Enterable</th>
<th>You can enter information in the field.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Example:</td>
<td>ID:</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Display only</th>
<th>You cannot enter information in the field.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Example:</td>
<td>ID: 0000000000 [Blizzard T Husky]</td>
</tr>
</tbody>
</table>

Validated Fields

Many fields only accept codes from a defined List of Values (LOV) and you can tell that a field has predefined values if the field name appears in blue. The code/description lookup feature helps you enter information into validated fields. This feature will enable you to

- Enter a complete code or description
- Look up a code/description based on a partial entry
- Display the entire LOV and select a code.

Click on the arrow icon or press function key F9 to display the entire LOV for a field.
Navigating through Banner

Banner provides several ways to navigate through the system:

<table>
<thead>
<tr>
<th><strong>Main menu</strong></th>
<th>You can select from a list of the menus, forms and QuickFlows in Banner.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Go To</strong></td>
<td>You can access a menu, form or QuickFlow by its seven-character name, you can use the code/description lookup feature, or arrow up or down to access forms used in this session.</td>
</tr>
<tr>
<td><strong>Object Search</strong></td>
<td>You can access a form or QuickFlow if you know part of its name, description or type.</td>
</tr>
<tr>
<td><strong>Right Click on Canvas</strong></td>
<td>You can access other blocks of information or commonly used functions</td>
</tr>
<tr>
<td><strong>Iconic buttons</strong></td>
<td>You can access another form or window related to the current record or field.</td>
</tr>
<tr>
<td><strong>Mouse</strong></td>
<td>You can click an iconic button, field, record, block or window that is currently displayed.</td>
</tr>
<tr>
<td><strong>Keyboard equivalents</strong></td>
<td>You can use the keyboard to access a form, window, block or field.</td>
</tr>
<tr>
<td><strong>QuickFlow</strong></td>
<td>You can automatically access forms that are linked in a chain.</td>
</tr>
<tr>
<td><strong>Last 10 forms in the File pull-down menu</strong></td>
<td>You can quickly re-access a form that was previously opened in the current session.</td>
</tr>
</tbody>
</table>

Object Search

You can use Object Search to access a form, job or QuickFlow if you know part of its name, description, or type.

1. Double-click the **Go To** field on the Main Menu.

2. Type in your search criteria on the Object Search Form. You can use the % wildcard in any field.

3. Perform a Query function: A list of all matches appears. **Mouse** or **Query > Execute**

   **Keyboard** **F8 key**

4. Scroll to the desired name.
5. Double-click the desired name or click the Start button.

Searching in Banner

Banner forms have ID fields for students (persons). You can always enter the complete ID in an ID field if you know the person’s ID number as instructed below, or you can use the ID/name search feature on the current form.

Before following the procedures below access the Banner Form from which you want to look up information (e.g. SPAIDEN, TSAAREV)

**Entering a complete ID:**

1. Perform a Clear Record if any details are in the key block:
   - **Mouse** ✔️ Record > Clear
   - **Keyboard** ⬠ Shift+F4

2. In the **ID** field type in the full ID, e.g. 234567891.

3. Press <Enter>. The ID and name will automatically appear in the key block.

**Entering a complete name:**

1. Perform a Clear Record if any details are in the key block:
   - **Mouse** ✔️ Record > Clear
   - **Keyboard** ⬠ Shift+F4

2. <Tab> to the **Name** field which is the unlabelled field next to the ID field.

3. Type in the name, separating the surname and first name/other names with a comma. You can type in upper or lower case and you don’t have to leave a space after the comma.

   Examples: Smith, Robert, James

   smith,robert,james

4. Press <Enter>.
   - If one name is found, the ID and name will automatically appear on the form.
   - If more than one person with that name is found, the **ID and Name Extended Search** window will be displayed (shown below) with a list of persons with that name.

See page 23 for details on the ID and Name Extended Search window
Using ‘wildcards’ in searches

Wildcards, or Oracle wildcards as they are referred to in Banner, are characters that will match any character or combination of characters. Wildcards are used in partial ID and name searches as shown below.

The wildcard characters used in Banner are:

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Example Usage</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>%</td>
<td>Represents any number of unspecified characters.</td>
<td>smith, s% searches for all persons with the surname Smith whose first name starts with S.</td>
<td></td>
</tr>
<tr>
<td>_</td>
<td>Represents one occurrence of an unspecified character.</td>
<td>sm%, s% searches for all persons whose surname starts with Sm and whose first name starts with S.</td>
<td>(SOAIDEN form only)</td>
</tr>
<tr>
<td>,</td>
<td>Searches for all persons with the letters in the first name.</td>
<td>, Sara% searches for all persons with the letters Sara in the first name.</td>
<td></td>
</tr>
<tr>
<td>%,</td>
<td>Searches for all persons with the first name.</td>
<td>%, Sarah% searches for all persons with the first name Sarah.</td>
<td></td>
</tr>
<tr>
<td>%th</td>
<td>Searches for all entries that have th as the last two characters.</td>
<td>%th searches for all entries that have th as the last two characters.</td>
<td></td>
</tr>
<tr>
<td>%mi%</td>
<td>Searches and displays every record on the current form in the ID and Name Extended Search window.</td>
<td>%mi% searches and displays every record on the current form in the ID and Name Extended Search window.</td>
<td></td>
</tr>
<tr>
<td>%21%</td>
<td>Searches for all IDs that start with 21.</td>
<td>_m% searches for all entries that have m as the second character.</td>
<td>(Note! Search only available in the Person Search Form – SOAIDEN – see page 7).</td>
</tr>
</tbody>
</table>

Searching by partial ID:
1. Type in a partial ID in the ID field using a wildcard, e.g. 21%.
2. Press <Enter>.
   - If one match is found, the ID and name will automatically appear on the form.
   - If more than one match is found, the ID and Name Extended Search window will be displayed with a list of matches to choose from. The field next to the Search Results field will show the number of matches.
   - If you are in SPAIDEN, this search will take you to the common matching entry form GOAMTCH.

Searching by partial name:
1. Make sure the ID field is blank (if not, press the <Delete> key to remove ID).
2. <Tab> to the Name field which is the unlabelled field next to ID field.
3. Type in a partial name in the Name field using a wildcard(s) (see section above on ‘Using Wildcards’).
4. Press <Enter>.
   - If one match is found, the ID and name will automatically appear on the form.
   - If more than one match is found, the ID and Name Extended Search window will be displayed with a list of matches to choose from. The field next to the Search Results field will show the number of matches.
THE ID AND NAME EXTENDED SEARCH WINDOW

Enter search criteria then press Execute Query or select button to reduce search.

- City:
- State or Province:
- ZIP or Postal Code:
- Name Type:
- SSN/SIN/TIN:
- Birth Date:
- Gender:

Tips

- To cancel the query, click on the cancel button.
- To clear the criteria from the Reduce Search By block, click on the rollback button.

Narrowing (reducing) searches:

1. Click on the Person, Non-Person, or Both radio button in the Reduce Search By block in the ID and Name Extended Search window (to identify the kind of ID you want to search).
2. Type in the search criteria in the fields in the Reduce Search By block, e.g., a date of birth (see section on data format for entering dates).
3. Click on the Reduce Search icon and then the arrow icon in the search results field to see the matches.

4. If necessary, go back to step 2 to further reduce the search.

PERSON SEARCH FORM (SOAIDEN)

Search forms are also available in Banner to search for a person or non-person by name or ID. However, the recommended and preferred way of searching in Banner is on pages 22 and 23.

1. Click on the Person Search Detail button either in the ID and Name Extended Search window or in the key block of a form to display the Person Search form (e.g. SPAIDEN, TSAAREV)

2. If there is more than one search option, e.g. Person or Non-Person, an Option List will appear. Click on the option you want to search on.

3. <Tab> to Last Name field and type in the surname and/or use a wildcard, e.g. Ste%.

4. Perform a query function. The form will show all IDs with matching information.
   - **Mouse**: or **Query > Execute**
   - **Keyboard**: Function key F8

5. <Double-click> the desired ID. The ID and name will return to the form.
PERSON SEARCH DETAIL FORM (SOAIDNS)

The Person Search Detail form is useful for searching and displaying address information, IDs, date of births and details on the student’s program information. This form is display only.

Accessing the Form

Go: [SOAIDNS]

1. Type in the information that you know in the appropriate field, e.g. Last Name

   *The fields in this form are case sensitive.*

2. Perform a Query function. The form will show all matching information.

   **Mouse**  
   or **Query > Execute**

   **Keyboard**  
   or **F8 function key**

3. Matching information will be displayed

Address information for the selected student (highlighted in blue in first block)

Information in this block is coming from other modules in Banner

---

### PERSON SEARCH DETAIL FORM (SOAIDNS)

<table>
<thead>
<tr>
<th>ID</th>
<th>Last Name</th>
<th>First Name</th>
<th>Middle Name</th>
<th>Birth Date</th>
<th>Sex</th>
<th>Change Indicator</th>
</tr>
</thead>
</table>

Address Details

<table>
<thead>
<tr>
<th>Type</th>
<th>Street</th>
<th>City</th>
<th>State or Province</th>
<th>ZIP or Postal Code</th>
<th>Telephone</th>
<th>From Date</th>
<th>To Date</th>
<th>Inactive Indicator</th>
</tr>
</thead>
<tbody>
<tr>
<td>MA</td>
<td>123 Grand Ave</td>
<td>Winter</td>
<td>MO</td>
<td>40005</td>
<td>666-001234</td>
<td>01-NOV-2001</td>
<td>01-NOV-2001</td>
<td>01-NOV-2001</td>
</tr>
<tr>
<td>MO</td>
<td>123 Grand Ave</td>
<td>Winter</td>
<td>MO</td>
<td>40005</td>
<td>666-001234</td>
<td>01-NOV-2001</td>
<td>01-NOV-2001</td>
<td>01-NOV-2001</td>
</tr>
</tbody>
</table>

General Learner

<table>
<thead>
<tr>
<th>Term</th>
<th>Status</th>
<th>Residence</th>
<th>Class</th>
<th>Full or Part Time</th>
<th>Activity Date</th>
</tr>
</thead>
</table>

Curricula Summary

<table>
<thead>
<tr>
<th>Priority</th>
<th>Term</th>
<th>Program</th>
<th>Catalog</th>
<th>Student Type: Level</th>
<th>Campus</th>
<th>Rate: College</th>
<th>Degree</th>
</tr>
</thead>
</table>

Field of Study Summary

<table>
<thead>
<tr>
<th>Priority</th>
<th>Term</th>
<th>Type</th>
<th>Field of Study</th>
<th>Department</th>
<th>Attached to Major</th>
</tr>
</thead>
</table>
Using ‘Sounds Like’ searches

A ‘sounds like’ search, or Oracle Soundex search as it is referred to in Banner, can be used if you do not know the ID number or name but think you know what it sounds like; or perhaps you think the name could be one of a few possibilities, e.g. White, Waite or Wyatt. A ‘sounds like’ search can be used to narrow the search results. You can enter as much or as little of the name as you know, using upper, lower or mixed case. As long as the first letter is correct the search will retrieve names with a similar pattern of characters.

1. Click on the Search button next to the Name field on the form.

2. From the Option List click on Person on Non-Person Search.

3. Click on the Exit button or Cancel Query function button to activate the Options menu.

4. Click on Search Using ‘Sounds Like’ option. The Soundex Search window will appear.

5. Type in the name you think it sounds like or a string of characters for the name you want to find, e.g. White, Smth etc.

6. Perform a query function:
   - **Mouse**: or Query > Execute
   - **Keyboard**: Function key F8

   The search form shows all IDs for names that could match with the sounds like name/characters.

7. <Double-click> the desired ID. The ID and name will be returned to the form.
Using the Calendar

You can click the calendar icon  next to any date field to display the calendar. The calendar highlights the current date. You can double-click a date on the calendar to return it to the calling form. You can access the calendar by typing GUACALN in the Go To field or choosing it in the Help menu. When accessed this way the calendar works independently of any form or field. You cannot select a date and return it to a form.

Double-click any date on the calendar to return it to the Date field on the form.

Using the Calculator

You can double-click any updatable numeric field to display the calculator. If the numeric field has a value, the calculator shows that value. You can use the mouse, number keys on the keyboard or the numeric keypad to make calculations. When you are done click the OK button to return the calculated value to the calling form.

You can also access the calculator by typing GUACALC in the Go To field or choosing it in the Help menu. However, when accessed this way the calculator works independently of any form or field and you cannot return the calculation to a form.
Using Help

Banner has several kinds of help that can give you assistance.

**In the Help menu:**

**Online Help**  
Available for each system.

**Dynamic Help**  
This is used to show the database field for a field on the form and in some cases a field description.

**Banner Bookshelf**  
This tool lets you access Banner documents provided by Sungard SCT directly from your computer. This is generic material and users should refer to their user manuals for documentation specific to Michigan Tech.

**At the bottom of the form:**

**Auto Hint**  
This hint at the bottom of the form briefly describes the field where the cursor is located. Error and processing messages also appear here.

```
Field description

Address type: LIST for codes; COUNT HITS for addresses;
Record: 1/1
List of Values

The semicolons separate the hints. It can also display keyboard equivalents, LIST to display person IDs, COUNT QUERY HITS to display non person IDs, DUP ITEM to create new ID.
```
My Banner

My Banner includes the forms, jobs, menus and Quick Flows that are most important in your daily work. You can access My Banner from the Main Menu. It’s tied to your Oracle user ID.

You can use these forms to create and copy personal menus:

- The My Banner Maintenance Form (GUAPMNU) lets you create and change your My Banner. The user ID associated with the person logged on to the system is shown above the left panel.
Adding an object to My Banner

1. Access the My Banner Maintenance Form by typing GUAPMNU in the Go To field.
2. Use the pull-down list above the left pane to select the object type you want to display. The left pane lists the objects of the selected type that can be added to the menu.
3. In the left pane, select (highlight) each object you want to add to the menu by double-clicking on the object’s name.
4. Repeat steps 2 and 3 for each object type you want to add to the menu.
5. Click in the right pane where you want to place the new menu items.
6. Click the Insert button in the middle of the form. The selected objects are added to the right pane below the place where you clicked.
7. Save the records:
   Mouse or File > Save
   Keyboard F10 function key

You can customize the object description by overtyping the name as shown below:

<table>
<thead>
<tr>
<th>Object</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPAIDEN</td>
<td>You can customize the description</td>
</tr>
<tr>
<td>FURFEED</td>
<td>Finance Feed Sweep Process gathers transactions from GURFEED and inserts them into...</td>
</tr>
<tr>
<td>FORTRN</td>
<td>Interface Process</td>
</tr>
</tbody>
</table>

Deleting an object from My Banner

1. Access the My Banner Maintenance Form by typing GUAPMNU in the Go To field.
2. In the right pane select the object(s) you want to delete by double-clicking on the name so it is highlighted.
3. Click the Remove button in the middle of the form to delete the object. If you want to remove all of the objects click on the Delete All button.
4. Save the records:
   Mouse or File > Save
   Keyboard F10 function key

Adding an object if you know the object’s seven-character name

1. Access the My Banner Maintenance Form by typing GUAPMNU in the Go To field.
2. Place the cursor in a blank Object field in the right pane.
3. Type in the object’s seven-character name, e.g. SPAIDEN.
4. Press <Enter>. The object’s name and description appear in the right pane.
5. Save the records:
   Mouse or File > Save
   Keyboard F10 function key
### Appendix 1: Quick Reference Chart

<table>
<thead>
<tr>
<th><strong>File</strong></th>
<th><strong>Edit</strong></th>
<th><strong>Block</strong></th>
<th><strong>Field</strong></th>
<th><strong>Record</strong></th>
<th><strong>Query</strong></th>
<th><strong>Help</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Direct Access</td>
<td>Cut</td>
<td>Previous</td>
<td>Previous</td>
<td>Previous</td>
<td>Enter</td>
<td>Online Help</td>
</tr>
<tr>
<td>Object Search</td>
<td>Copy</td>
<td>Next</td>
<td>Next</td>
<td>Clear</td>
<td>Execute</td>
<td>Dynamic Help Query</td>
</tr>
<tr>
<td>QuickFlow</td>
<td>Paste</td>
<td>Clear</td>
<td>Scroll Up</td>
<td>Cancel</td>
<td>List</td>
<td>Dynamic Help Edit</td>
</tr>
<tr>
<td>Select</td>
<td>Edit</td>
<td>Duplicate</td>
<td>Scroll Down</td>
<td></td>
<td></td>
<td>Help (Item Properties)</td>
</tr>
<tr>
<td>Rollback</td>
<td></td>
<td></td>
<td>Clear</td>
<td></td>
<td></td>
<td>Show Keys</td>
</tr>
<tr>
<td>Save</td>
<td></td>
<td></td>
<td>Remove</td>
<td>Fetch Next</td>
<td>Show Keys</td>
<td></td>
</tr>
<tr>
<td>Refresh</td>
<td></td>
<td></td>
<td>Insert</td>
<td>Set</td>
<td>Display Error</td>
<td></td>
</tr>
<tr>
<td>Print</td>
<td></td>
<td></td>
<td>Duplicate</td>
<td></td>
<td>Calendar</td>
<td></td>
</tr>
<tr>
<td>Exit</td>
<td></td>
<td></td>
<td>Lock</td>
<td></td>
<td>Calculator</td>
<td></td>
</tr>
<tr>
<td>Exit QuickFlow</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Extract Data with Key</td>
<td></td>
</tr>
<tr>
<td>Exit SCT Banner</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Extract Data no Key</td>
<td></td>
</tr>
<tr>
<td>Return to Menu</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>About SCT Banner</td>
<td></td>
</tr>
</tbody>
</table>

**Key**

*Keyboard equivalents are shown in italics. Some keystrokes vary from one environment to another in Banner.*

- F2 - Displays the Tab Menu
- F3 - Used to duplicate a field/item also used to drill down to detail information
- F5 - Displays Go To field so you can access another form